Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-10530

compile failed in esb.validator

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Done
    • 3.3.0.Beta1
    • 3.3.0.Beta1
    • esb
    • None

    Description

      After switching to newer target platform (JBIDE-10289), one class is failing to compile:

      https://hudson.qa.jboss.com/hudson/view/DevStudio/view/DevStudio_Trunk/job/jbosstools-3.3_trunk.component--esb/610/console

      [INFO] org.jboss.tools.esb.validator ..................... FAILURE [1.071s]
      
      [ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:0.13.0:compile (default-compile) on project org.jboss.tools.esb.validator: Compilation failure: Compilation failure:
      [ERROR] /mnt/hudson_workspace/workspace/jbosstools-3.3_trunk.component--esb/sources/plugins/org.jboss.tools.esb.validator/src/org/jboss/tools/esb/validator/ui/ESBConfigurationBlock.java (at line 90):[-1,-1]
      [ERROR] protected String getQualifier() {
      [ERROR] ^^^^^^^^^^^^^^
      [ERROR] The method getQualifier() of type ESBConfigurationBlock must override a superclass method
      [ERROR] 
      [ERROR] /mnt/hudson_workspace/workspace/jbosstools-3.3_trunk.component--esb/sources/plugins/org.jboss.tools.esb.validator/src/org/jboss/tools/esb/validator/ESBCoreValidator.java (at line 375):[-1,-1]
      [ERROR] protected String getPreferencePageId() {
      [ERROR] ^^^^^^^^^^^^^^^^^^^^^
      [ERROR] The method getPreferencePageId() of type ESBCoreValidator must override a superclass method
      
      

      Attachments

        Issue Links

          Activity

            People

              nickboldt Nick Boldt
              nickboldt Nick Boldt
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: