Uploaded image for project: 'JBeret'
  1. JBeret
  2. JBERET-467

Known high severity security vulnerability detected in com.fasterxml.jackson.core:jackson-databind >= 2.9.0, < 2.9.8

    Details

      Description

      github reports this security vulnerability with jackson library. This is the current declared version of jackson library:

      <version.com.fasterxml.jackson>2.9.5</version.com.fasterxml.jackson>
      

      Need to evaluate and upgrade to more recent versions (2.9.8 or later).

      The following is copied from the related github alert issue for easy reference:

      7 com.fasterxml.jackson.core:jackson-databind vulnerabilities found in pom.xml an hour ago
      Remediation
      Upgrade com.fasterxml.jackson.core:jackson-databind to version 2.9.8 or later. For example:

      <dependency>
      <groupId>com.fasterxml.jackson.core</groupId>
      <artifactId>jackson-databind</artifactId>
      <version>[2.9.8,)</version>
      </dependency>
      Always verify the validity and compatibility of suggestions with your codebase.

      Details
      CVE-2018-19360 More information
      high severity
      Vulnerable versions: >= 2.9.0, < 2.9.8
      Patched version: 2.9.8
      FasterXML jackson-databind 2.x before 2.9.8 might allow attackers to have unspecified impact by leveraging failure to block the axis2-transport-jms class from polymorphic deserialization.

      CVE-2018-19362 More information
      high severity
      Vulnerable versions: >= 2.9.0, < 2.9.8
      Patched version: 2.9.8
      FasterXML jackson-databind 2.x before 2.9.8 might allow attackers to have unspecified impact by leveraging failure to block the jboss-common-core class from polymorphic deserialization.

      CVE-2018-19361 More information
      high severity
      Vulnerable versions: >= 2.9.0, < 2.9.8
      Patched version: 2.9.8
      FasterXML jackson-databind 2.x before 2.9.8 might allow attackers to have unspecified impact by leveraging failure to block the openjpa class from polymorphic deserialization.

      CVE-2018-14718 More information
      high severity
      Vulnerable versions: >= 2.9.0, < 2.9.7
      Patched version: 2.9.7
      FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to execute arbitrary code by leveraging failure to block the slf4j-ext class from polymorphic deserialization.

      CVE-2018-14720 More information
      high severity
      Vulnerable versions: >= 2.9.0, < 2.9.7
      Patched version: 2.9.7
      FasterXML jackson-databind 2.x before 2.9.7 might allow attackers to conduct external XML entity (XXE) attacks by leveraging failure to block unspecified JDK classes from polymorphic deserialization.

      CVE-2018-14719 More information
      high severity
      Vulnerable versions: >= 2.9.0, < 2.9.7
      Patched version: 2.9.7
      FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to execute arbitrary code by leveraging failure to block the blaze-ds-opt and blaze-ds-core classes from polymorphic deserialization.

      CVE-2018-14721 More information
      high severity
      Vulnerable versions: >= 2.9.0, < 2.9.7
      Patched version: 2.9.7
      FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to conduct server-side request forgery (SSRF) attacks by leveraging failure to block the axis2-jaxws class from polymorphic deserialization.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  cfang Cheng Fang
                  Reporter:
                  cfang Cheng Fang
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: