Uploaded image for project: 'JBoss Enterprise Spec APIs'
  1. JBoss Enterprise Spec APIs
  2. JBEE-73

Create a uber-jar for the JBoss JavaEE APIs

    Details

      Description

      My Windows users are having problems..

      Windows has a limitation on how long the ClassPath can be, when you start to include libraries like, jbossas-client(249 deps) and jboss-javaee-6.0 windows refuse to execute the java process.

      http://community.jboss.org/message/586381#586381

      Would it be possible to release a uber-jar v. of the jboss-javaee-6.0 pom? Basically merge it into one artifact. Most users don't care about the individual specs, they use EE. And as long as the pom is there as well, they have both options.

      <dependency>
      <groupId>org.jboss.spec</groupId>
      <artifactId>jboss-javaee-6.0-all</artifactId> <-- using a different artifact id is probably easier to setup -->
      <version>1.0.0.Final</version>
      <type>jar</type> <-- a single jar -->
      </dependency>

      http://maven.apache.org/plugins/maven-shade-plugin/

      ?

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                pgier Paul Gier
                Reporter:
                aslak Aslak Knutsen
              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: