Uploaded image for project: 'JBoss Enterprise Application Platform'
  1. JBoss Enterprise Application Platform
  2. JBEAP-23440

Some Java releases now support TLSv1.2 with PKCS#11 / FIPS mode

    XMLWordPrintable

Details

    Description

      https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.2/html-single/how_to_configure_server_security/index#fips_compliant_cryptography

      Warning box in "1.2.12.1. Enable FIPS 140-2 Cryptography for SSL/TLS on Red Hat Enterprise Linux 7 and Later" is now out of date.

      Several versions of Java now support TLSv1.2 with PKCS#11 so box should be updated to reflect that. See https://bugs.openjdk.java.net/browse/JDK-8029661

      Updated versions include Oracle 8u192 and later, OpenJDK 8u212 and later, Java 11.0.3

      Attachments

        Issue Links

          Activity

            People

              eameh1@redhat.com Emmanuel Ameh
              rhn-support-cdolphy Chris Dolphy
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated: