Uploaded image for project: 'JBoss Enterprise Application Platform'
  1. JBoss Enterprise Application Platform
  2. JBEAP-21946

[GSS](7.3.z) HAL-1750 - Web Console returning WFLYCTL0030: No resource definition is registered for address

    XMLWordPrintable

Details

    • Hide
      • Configure a domain with a DC and a HC with servers
      • Deploy a .war application
      • Navigate to Runtime -> hosts -> hc -> server -> Web undertow -> Deployment and click on the deployed application
      • No resource definition error is thrown, see attachment.
      Show
      Configure a domain with a DC and a HC with servers Deploy a .war application Navigate to Runtime -> hosts -> hc -> server -> Web undertow -> Deployment and click on the deployed application No resource definition error is thrown, see attachment.
    • +

    Description

      The trick to reproduce is to have a DC and an and additional HC. This issue is not reproducible when the Undertow -> Deployment tab is reached out from the DC, for example, master HC.

      The problem is not on the server-side, it was verified manually that running the operation via CLI works without any issue. It seems a problem derived from how HAL mounts the address to access to Deployment tab when the tab is reached out from the HC which is not the DC.

      Attachments

        Issue Links

          Activity

            People

              chaowan@redhat.com Chao Wang
              yborgess1@redhat.com Yeray Borges Santana
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: