Details

    • Type: Bug
    • Status: Verified (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 7.4.0.CD19
    • Component/s: OpenShift
    • Labels:
      None
    • Target Release:
      CD

      Description

      EAP is trying to load keycloak-wildfly-subsystem version 4.6.0.Final-redhat-00002. But CD19 image contains keycloak-wildfly-subsystem 9.0.0.temporary-redhat-00088. Temporary keyword looks suspicious.

      WARN ... Failed to define class org.keycloak.subsystem.adapter.extension.KeycloakExtension in Module "org.keycloak.keycloak-wildfly-subsystem" version 4.6.0.Final-redhat-00002 from local module loader...: org.jboss.modules.ModuleLoadError: org.jboss.metadata
      ERROR ... WFLYCTL0013: Operation ("add") failed - address: ([("extension" => "org.keycloak.keycloak-adapter-subsystem")]): org.jboss.modules.ModuleLoadError: org.jboss.metadata
      

      Full log

      Keycloak-servlet-oauth-client artifact is missing in CD19 image.

      Pod log from EAP 7.3.0.CR4 doesn't have this type of errors.

      Steps to reproduce:

      • Use CD19 settings on openshift-eap-tests (see for example this commit)
      • mvn clean test -B -Pcd -Dtest=GalleonSsoTest

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  luck3y Ken Wills
                  Reporter:
                  mkopecky Marek Kopecky
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: