Uploaded image for project: 'JBoss Enterprise Application Platform'
  1. JBoss Enterprise Application Platform
  2. JBEAP-18585

[GSS](7.3.z) MODULES-378 - Symbolic links in config files are not working

    XMLWordPrintable

Details

    • Hide
      • Install EAP 7
      • Deploy an application that uses properties files
      • Use a xml similar to the following:
        module.xml
        <?xml version="1.0" encoding="UTF-8"?>
        <module xmlns="urn:jboss:module:1.1" name="com.package.net">
        <resources>
        <resource-root path="./files"/>
        </resources>
        </module>
        Where files is a symbolic link, it does not matter if it is relative or absolute path.
      Show
      Install EAP 7 Deploy an application that uses properties files Use a xml similar to the following: module.xml <?xml version="1.0" encoding="UTF-8"?> <module xmlns="urn:jboss:module:1.1" name="com.package.net"> <resources> <resource-root path="./files"/> </resources> </module> Where files is a symbolic link, it does not matter if it is relative or absolute path.
    • +

    Description

      After migrating from EAP 7.0.0 to EAP 7.2.5, ResourceBundle.getBundle() stopped working with this exception:
      ERROR [stderr] (default task-1) java.util.MissingRosurceException: Cant’t find bundle for base name your.package.properties, locale es_ES

      It crashes when using a symbolic link in modules.xml, if you set a relative or absolute path which is not a symlink, it works

      Attachments

        Issue Links

          Activity

            People

              spyrkob Bartosz Spyrko-Smietanko
              spyrkob Bartosz Spyrko-Smietanko
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: