Uploaded image for project: 'JBoss Enterprise Application Platform'
  1. JBoss Enterprise Application Platform
  2. JBEAP-15310

[7.1] NS typo in various jboss-all.xml examples

    XMLWordPrintable

Details

    Description

      This issue was identified by Matthias Trapp in the Red Hat Customer Discussion forum.

      There are various examples for jboss-all.xml in the docs where 'umlns' is a typo for 'xmlns'. For example: https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.0/html/configuration_guide/deploying_applications#control_order_deployments

      I have confirmed with bstansbe@redhat.com that despite it appearing in various upstream examples and test cases, this is indeed a typo. He has opened WFLY-10921 to fix the upstream occurrences.

      Why this typo hasn't caused a lot of issues despite its longevity:

      A document with this typo will fall under the 'no xmlns' category. The parser ignores other attributes on the element, which is why the typo doesn't cause problems.

      Attachments

        Issue Links

          Activity

            People

              lcosti.redhat Lucas Costi (Inactive)
              lcosti.redhat Lucas Costi (Inactive)
              Nikoleta Ziakova Nikoleta Ziakova (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: