Uploaded image for project: 'JBoss Enterprise Application Platform'
  1. JBoss Enterprise Application Platform
  2. JBEAP-12716

Apache Avro version not compatible with Hibernate Search requirements

    XMLWordPrintable

Details

    • Hide

      Checkout Hibernate Search (upstream) code from branch 5.5 (the branch included in EAP).

      Override the wildflyVersion property so to not test with WildFly 10 but the latest build of EAP.

      Integration tests using clustering over JMS will fail.

      Show
      Checkout Hibernate Search (upstream) code from branch 5.5 (the branch included in EAP). Override the wildflyVersion property so to not test with WildFly 10 but the latest build of EAP. Integration tests using clustering over JMS will fail.

    Description

      The version of Apache Avro was updated and is now no longer compatible with Hibernate Search, which is the reason for which Avro is included: according to wildfly-dev and some more chats, nobody else needs this update so the safest action would be to revert to the previous version.

      Attachments

        Issue Links

          Activity

            People

              sgrinove Sanne Grinovero
              sgrinove Sanne Grinovero
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: