Details

      Description

      UndertowDefaultConfigUpgradeTestCase tests that if we parse and marshal a particular undertow subsystem config file using the WildFly 8 xsd (file presumably matching what we shipped in our standard WildFly 8 config) that the marshaled output will match a config file that uses the current xsd.

      This won't work once WFCORE-2704 is fixed because the old config file includes default values (which should be marshaled since they are in the config) while the new file does not. It's basically a bug that parsing these two documents results in the same marshaled output.

      This test doesn't serve any purpose any more (we've long since established that a WF 8 config can works in WF 8.1, when the schema changed a lot, and there's a different test that also confirms this) and keeping it around is blocking the important WFCORE-2704 fix.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  brian.stansberry Brian Stansberry
                  Reporter:
                  brian.stansberry Brian Stansberry
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: