Uploaded image for project: 'Red Hat CodeReady Studio (devstudio)'
  1. Red Hat CodeReady Studio (devstudio)
  2. JBDS-5016

Installing BYOE from Studio Jar is not possible

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 12.21.0.AM1
    • Fix Version/s: 12.21.0.AM1
    • Component/s: installer
    • Labels:
      None
    • Steps to Reproduce:
      Hide
      1. Download-unzip/install and start eclipse 2021-06.
      2. Download Studio jar [1].
      3. Install new software -> point to your local studio jar
      4. Assert: No remediation page and installation passes

      Actual result: remediation with above mentioned conflicts.

       

      [1]https://devstudio.redhat.com/12/staging/builds/devstudio-12.21.0.AM1-build-product/2021-09-02_11-10-15-B276/all/codereadystudio-12.21.0.AM1-v20210902-1001-B276-installer-standalone.jar

      Show
      Download-unzip/install and start eclipse 2021-06. Download Studio jar  [1] . Install new software -> point to your local studio jar Assert: No remediation page and installation passes Actual result: remediation with above mentioned conflicts.   [1] :  https://devstudio.redhat.com/12/staging/builds/devstudio-12.21.0.AM1-build-product/2021-09-02_11-10-15-B276/all/codereadystudio-12.21.0.AM1-v20210902-1001-B276-installer-standalone.jar
    • Docs QE Status:
      NEW
    • [QE] How to address?:
      ---
    • [QE] Why QE missed?:
      ---

      Description

      Cannot perform installation of Studio from installation jar (12.21.0.AM1-B276) archive into eclipse 2021-06 R jee. I got:

       

      
      Cannot complete the install because of a conflicting dependency.
       Software being installed: Red Hat CodeReady Studio (Branded Product) 12.21.0.AM1-v20210902-1001-B276 (com.jboss.devstudio.core.package 12.21.0.AM1-v20210902-1001-B276)
       Software currently installed: Eclipse IDE for Enterprise Java and Web Developers 4.20.0.20210612-1200 (epp.package.jee 4.20.0.20210612-1200)
       Only one of the following can be installed at once: 
       Core Runtime 3.22.0.v20210506-1025 (org.eclipse.core.runtime 3.22.0.v20210506-1025)
       Core Runtime 3.23.0.v20210730-2035 (org.eclipse.core.runtime 3.23.0.v20210730-2035)
       Cannot satisfy dependency:
       From: Red Hat CodeReady Studio (Branded Product) 12.21.0.AM1-v20210902-1001-B276 (com.jboss.devstudio.core.package 12.21.0.AM1-v20210902-1001-B276)
       To: org.eclipse.equinox.p2.iu; toolingcom.jboss.devstudio.core.package.configuration [12.21.0.AM1-v20210902-1001-B276,12.21.0.AM1-v20210902-1001-B276]
       Cannot satisfy dependency:
       From: Eclipse IDE for Enterprise Java and Web Developers 4.20.0.20210612-1200 (epp.package.jee 4.20.0.20210612-1200)
       To: org.eclipse.equinox.p2.iu; org.eclipse.platform.feature.group [4.20.0.v20210611-1600,4.20.0.v20210611-1600]
       Cannot satisfy dependency:
       From: Eclipse Platform 4.20.0.v20210611-1600 (org.eclipse.platform.feature.group 4.20.0.v20210611-1600)
       To: org.eclipse.equinox.p2.iu; org.eclipse.core.runtime [3.22.0.v20210506-1025,3.22.0.v20210506-1025]
       Cannot satisfy dependency:
       From: toolingcom.jboss.devstudio.core.package.configuration 12.21.0.AM1-v20210902-1001-B276
       To: org.eclipse.equinox.p2.iu; toolinggtk.linux.x86_64org.eclipse.core.runtime [12.21.0.AM1-v20210902-1001-B276,12.21.0.AM1-v20210902-1001-B276]
       Cannot satisfy dependency:
       From: toolinggtk.linux.x86_64org.eclipse.core.runtime 12.21.0.AM1-v20210902-1001-B276
       To: osgi.bundle; org.eclipse.core.runtime 3.23.0.v20210730-2035
      
      

        Attachments

          Activity

            People

            Assignee:
            stephane.bouchet Stephane Bouchet
            Reporter:
            odockal@redhat.com Ondrej Dockal
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: