Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 12.9.0.GA
    • Fix Version/s: 12.18.0.AM1
    • Component/s: central
    • Labels:
      None
    • Sprint:
      devex #159 December 2018, devex #161 January 2019, devex #162 February 2019, devex #163 March 2019, devex #164 April 2019, devex #165 April 2019, devex #166 May 2019, devex #167 June 2019, devex #168 June 2019, devex #169 July 2019, devex #172 Sep 2019, devex #170 Aug 2019, devex #171 Aug 2019, devex #173 Oct 2019, devex #174 Oct 2019, devex #175 Nov 2019, devex #176 Nov/Dec 2019
    • Story Points:
      5
    • Steps to Reproduce:
      Hide

      a) Install devstudio and run it
      b) wait 60 min with opened devstudio, do nothing with the devstudio
      c) issue will appear

      Show
      a) Install devstudio and run it b) wait 60 min with opened devstudio, do nothing with the devstudio c) issue will appear
    • Docs QE Status:
      NEW

      Description

      This issue has been successfully reproduced on the following OSes:

      • Fedora 28
      • Fedora 29, JDK 8
      • RHEL 7.7, JDK 8

      This issue is not reproducible on the following OSes:

      • OS X, JDK 11
      • Windows 10, JDK 8

      Details describing this issue:

      There is "openInIDE" used in 3 places in "main.min.js" in central source code*. When the central reloads and works normally, "openInIDE" is a function (probably defined in Java code or somewhere out of the "main.min.js" file) with following implementation:

      function openInIDE() {
      var result = callJava(1, '9aee3b4a3f3b40ed26f47d66375b25e3', Array.prototype.slice.call(arguments));
      if (typeof result == 'string' && result.indexOf('org.eclipse.swt.browser.error') == 0)

      { var error = new Error(result.substring(29)); throw error; }

      return result;
      }

      After the issue appears, "typedef openInIDE" is undefined, which causes probably the issues.

      *Additional information to the 3 places, where "openInIDE" appears - it appears in 2 functions:

      • registerButtonClicks() - here is the "openInIDE" needed for loading and displaying the central correctly
      • delegateToIDE(a, b) - here is the "openInIDE" needed for opening the wizard to the quickstart

      OLDER DESCRIPTION (does not describes the issue enough, but I decided to keep it for more details about the issue):
      ----------------------------------------------------------------------------------------------------------------------
      Sometimes central examples wizards fail to load and modal dialog is shown instead (screen attached).

      Nothing in Error log view.

      Restarting devstudio solves the issue.

      Adding screen and central tar of:
      devstudio-12.9.0.GA-v20180928-1629-B3448/workspaces/workspace/.metadata/.plugins/org.jboss.tools.central/central

      Addition info:
      Considering that central itests fails for this sometimes fresh installation without restart may cause this. Although it happen again after running devstudio for some time and restarting Central view.

        Gliffy Diagrams

          Attachments

          1. central.tar.gz
            358 kB
          2. image-2018-10-17-09-24-31-555.png
            image-2018-10-17-09-24-31-555.png
            18 kB
          3. issue-reproduced-19-11-16.png
            issue-reproduced-19-11-16.png
            723 kB
          4. screenshot-1.png
            screenshot-1.png
            188 kB

            Issue Links

              Activity

                People

                • Assignee:
                  jeffmaury Jeff MAURY
                  Reporter:
                  vprusa Vojtech Prusa
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated: