Uploaded image for project: 'Red Hat CodeReady Studio (devstudio)'
  1. Red Hat CodeReady Studio (devstudio)
  2. JBDS-4180

ClassNotFoundException thrown on devstudio start up

    Details

    • Docs QE Status:
      NEW

      Description

      When starting latest DevStudio 10.2.0.GA (build ID GA-v20161116-0039-B6472) I get following error in console output

      SLF4J: Actual binding is of type [ch.qos.logback.classic.util.ContextSelectorStaticBinder]
      Noop constructor
      java.lang.ClassNotFoundException: sun.jvmstat.monitor.MonitoredHost
      	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
      	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      	at org.eclipse.osgi.internal.framework.ContextFinder.loadClass(ContextFinder.java:132)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      	at org.jboss.tools.common.jdt.debug.tools.internal.Tools.invokeGetMonitoredHost(Tools.java:513)
      	at org.jboss.tools.common.jdt.debug.tools.internal.Tools.validateClassPathAndLibraryPath(Tools.java:365)
      	at org.jboss.tools.common.jdt.debug.tools.internal.Tools.reset(Tools.java:115)
      	at org.jboss.tools.common.jdt.debug.tools.internal.Tools.<init>(Tools.java:82)
      	at org.jboss.tools.common.jdt.debug.tools.internal.Tools.getInstance(Tools.java:73)
      	at org.jboss.tools.common.jdt.debug.tools.ToolsCore.getActiveProcessIds(ToolsCore.java:179)
      	at org.jboss.tools.jmx.jvmmonitor.internal.tools.JvmAttachHandler.updatesActiveJvms(JvmAttachHandler.java:100)
      	at org.jboss.tools.jmx.jvmmonitor.internal.tools.JvmAttachHandler$1.run(JvmAttachHandler.java:78)
      	at java.util.TimerThread.mainLoop(Timer.java:555)
      	at java.util.TimerThread.run(Timer.java:505)
      java.lang.ClassNotFoundException: sun.jvmstat.monitor.MonitoredHost
      	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
      	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      	at org.eclipse.osgi.internal.framework.ContextFinder.loadClass(ContextFinder.java:132)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      	at org.jboss.tools.common.jdt.debug.tools.internal.Tools.invokeGetMonitoredHost(Tools.java:513)
      	at org.jboss.tools.common.jdt.debug.tools.internal.Tools.invokeActiveVms(Tools.java:525)
      	at org.jboss.tools.common.jdt.debug.tools.ToolsCore.getActiveProcessIds(ToolsCore.java:179)
      	at org.jboss.tools.jmx.jvmmonitor.internal.tools.JvmAttachHandler.updatesActiveJvms(JvmAttachHandler.java:100)
      	at org.jboss.tools.jmx.jvmmonitor.internal.tools.JvmAttachHandler$1.run(JvmAttachHandler.java:78)
      	at java.util.TimerThread.mainLoop(Timer.java:555)
      	at java.util.TimerThread.run(Timer.java:505)
      
      

      problem is with openjdk version. With the lates 1.8.0_111 it works.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  rob.stryker Rob Stryker
                  Reporter:
                  mlabuda Marián Labuda
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: