Uploaded image for project: 'Red Hat CodeReady Studio (devstudio)'
  1. Red Hat CodeReady Studio (devstudio)
  2. JBDS-4049

Cannot install Devstudio 10.1.0.GA into Eclipse Neon.1 RC3 (remediation required)

    Details

      Description

      Steps to repro:

      1. Download eclipse-jee-neon-1-RC3-linux-gtk-x86_64.tar.gz, unpack and run

      2. Help > Eclipse Marketplace... > Search for "jboss" and install Red Hat JBoss Developer Studio 10.1.0.GA

      3. Remediation needed:

      Cannot complete the install because of a conflicting dependency.
        Software being installed: Red Hat JBoss Developer Studio (Core Features) 10.1.0.v20160902-1725 (com.jboss.devstudio.core.feature.feature.group 10.1.0.v20160902-1725)
        Software currently installed: JavaScript Development Tools 2.0.0.v201608301904 (org.eclipse.wst.jsdt.feature.feature.group 2.0.0.v201608301904)
        Only one of the following can be installed at once: 
          JavaScript Development Tools Core 2.0.0.v201603171403 (org.eclipse.wst.jsdt.core 2.0.0.v201603171403)
          JavaScript Development Tools Core 1.3.401.v201511181529 (org.eclipse.wst.jsdt.core 1.3.401.v201511181529)
          JavaScript Development Tools Core 2.0.0.v201608251059 (org.eclipse.wst.jsdt.core 2.0.0.v201608251059)
          JavaScript Development Tools Core 2.0.0.v201604281930 (org.eclipse.wst.jsdt.core 2.0.0.v201604281930)
          JavaScript Development Tools Core 2.0.0.v201605251700 (org.eclipse.wst.jsdt.core 2.0.0.v201605251700)
        Cannot satisfy dependency:
          From: Red Hat JBoss Developer Studio (Core Features) 10.1.0.v20160902-1725 (com.jboss.devstudio.core.feature.feature.group 10.1.0.v20160902-1725)
          To: com.jboss.devstudio.core.rpm.feature.feature.group [10.1.0.v20160902-1725]
        Cannot satisfy dependency:
          From: Red Hat JBoss Developer Studio (RPM Features) 10.1.0.v20160902-1725 (com.jboss.devstudio.core.rpm.feature.feature.group 10.1.0.v20160902-1725)
          To: org.eclipse.wst.jsdt.feature.feature.group [2.0.0.v201605311817]
        Cannot satisfy dependency:
          From: JavaScript Development Tools 2.0.0.v201605311817 (org.eclipse.wst.jsdt.feature.feature.group 2.0.0.v201605311817)
          To: org.eclipse.wst.jsdt.core [2.0.0.v201605251700]
        Cannot satisfy dependency:
          From: JavaScript Development Tools 2.0.0.v201608301904 (org.eclipse.wst.jsdt.feature.feature.group 2.0.0.v201608301904)
          To: org.eclipse.wst.jsdt.core [2.0.0.v201608251059]
      

      ds10.1_on_neon.1.RC3_remediation_needed.png

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  nickboldt Nick Boldt
                  Reporter:
                  nickboldt Nick Boldt
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: