Uploaded image for project: 'Red Hat CodeReady Studio (devstudio)'
  1. Red Hat CodeReady Studio (devstudio)
  2. JBDS-3055

cannot install Arquillian into JBDS because of missing Sapphire dependency

    XMLWordPrintable

Details

    • NEW

    Description

      JBT TP contains org.eclipse.sapphire, because Arquillian depends on it.
      JBDS TP does not (it also lacks Tern).

      So, when we create a TP for JBoss Central Early Access, it must include:

      • Arquillian
        • Sapphire + org.objectweb.asm
      • AngularJS
        • Tern.java
      • VJET
        • org.w3c.dom.events

      Because we don't have a mirror of Sapphire (it's included in Luna), we need to either create a TP now and publish it here [1], or create a mirror site in requirements/, and link that mirror from [1].

      [1] http://download.jboss.org/jbosstools/targetplatforms/jbtearlyaccesstarget/4.40.0.Beta3-SNAPSHOT/

      Attachments

        Activity

          People

            nickboldt Nick Boldt
            nickboldt Nick Boldt
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: