Uploaded image for project: 'JBoss Core Services'
  1. JBoss Core Services
  2. JBCS-947

mod_auth_kerb mod_rt and mod_bmx are listed in yum group jbcs-httpd24

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Done
    • httpd 2.4.37 GA
    • None
    • rpm
    • None

    Description

      mod_auth_kerb mod_rt and and mod_bmx are listed in yum group jbcs-httpd24 as below. These modules are dropped by JBCS-788 and JBCS-801 from JBCS Apache 2.4.37.GA.

      # yum groupinfo jbcs-httpd24
      Loaded plugins: amazon-id, product-id, search-disabled-repos, subscription-manager
      
      Group: Red Hat JBoss Core Services Pack Apache Server 2.4
       Group-Id: jbcs-httpd24
       Description: Packages which comprise the Red Hat JBoss Core Services Pack Apache Server 2.4 on RHEL 7
       Mandatory Packages:
         =jbcs-httpd24-httpd
         -jbcs-httpd24-httpd-libs
         =jbcs-httpd24-httpd-manual
         =jbcs-httpd24-mod_auth_kerb       <<<===
         =jbcs-httpd24-mod_bmx             <<<===
         =jbcs-httpd24-mod_cluster-native
         =jbcs-httpd24-mod_jk-ap24
         =jbcs-httpd24-mod_jk-manual
         =jbcs-httpd24-mod_ldap
         =jbcs-httpd24-mod_proxy_html
         =jbcs-httpd24-mod_rt              <<<===
         =jbcs-httpd24-mod_security
         =jbcs-httpd24-mod_session
         =jbcs-httpd24-mod_ssl
      

      If the user tries to install JBCS Apache 2.4.37 according to the following documentation, these modules will be installed on 2.4.37, but these are not supported modules.

      JBCS Apache HTTP Server Installation Guide 2.4.37
      2.2.2. Installing the Apache HTTP Server from RPM Packages
      https://access.redhat.com/documentation/en-us/red_hat_jboss_core_services/2.4.37/html/apache_http_server_installation_guide/installing_jboss_core_services_apache_http_server_on_red_hat_enterprise_linux#installing_the_apache_http_server_from_rpm_packages

      # subscription-manager repos --enable <repository>
      # yum groupinstall jbcs-httpd24
      

      In addition, current yum group jbcs-httpd24 does not contain jbcs-httpd24-mod_http2 package which is contained in zip distribution of JBCS Apache2.4.37.

      Attachments

        Activity

          People

            szappis@redhat.com Sokratis Zappis
            rhn-support-nagetsum Norito Agetsuma
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: