Uploaded image for project: 'Application Server 3  4  5 and 6'
  1. Application Server 3 4 5 and 6
  2. JBAS-6914

useJBossWebLoader not working when set to true

    Details

      Description

      The description for useJBossWebLoader in server/xxx/deployers/jbossweb.deployer/META-INF/war-deployers-jboss-beans.xml indicates that if it is set to true, then classes packaged within the WAR file should be visible to classes outside the WAR file. For AS 4.2.3, that is the case. However, for 5.0.1 and 5.1.0.CR1 it is not the case. Seems like a feature of prior versions that did not survive the move to the new vfs classloaders.

      As a test case, download the source code for JBoss in Action from http://code.google.com/p/jbia/downloads/list. Open the jbia-src/index.html file and follow the setup instructions. Then build target 01 in the jbia-src/ch03 directory. Try different values for useJBossWebLoader, using Scenario C to test it - you should get a clean response with no exceptions when useJBossWebLoader is set to true, and and exception when it is set to false.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                alesj AleŇ° Justin
                Reporter:
                peterj Peter Johnson
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: