Uploaded image for project: 'Infinispan'
  1. Infinispan
  2. ISPN-9962

Feature-packs should optionally depend on jdk-unsupported and sun.jdk

    Details

      Description

      Currently our feature-packs depend on both "sun.jdk" and "jdk.unsupported" in an inconsistent manner. For the latest versions of Wildfly, we need to use the latter, whilst for older ones we need to use the former. Therefore, for all modules that require access to unsupported classes, we must provide an optional dependency on both of the above modules.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  ryanemerson Ryan Emerson
                  Reporter:
                  ryanemerson Ryan Emerson
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: