Uploaded image for project: 'Infinispan'
  1. Infinispan
  2. ISPN-8633

Wildfly/EAP modules are unusable on Wildfly 11

    XMLWordPrintable

    Details

      Description

      I started with a fresh installation of Wildfly 11 and followed the instructions in the Infinispan User Guide: http://infinispan.org/docs/stable/user_guide/user_guide.html#infinispan_modules_for_wildfly . I didn't need to build or deploy an application to reproduce this. I followed 21.9 Infinispan modules for Wildfly under the section "Configuration" (steps 1-4, although I skipped step 4 since I didn't need any endpoints).

      First run produced the attached log (infinispan-9.1.3-wildfly-11.0.0-log1.txt). I then edited $JBOSS_HOME/modules/org/infinispan/server/endpoint/ispn-9.1/module.xml, as well as module.xml in server/hotrod and org/jgroups/extension to remove dependencies on "org.jboss.sasl". On startup, this produced the second stack trace (infinispan-9.1.3-wildfly-11.0.0-log2.txt).

      I tried Infinispan 8.2.8 (the version packaged with Wildfly 11.0.0) and Infinispan 9.2.0.Beta1 and got the same results. I made a forum post as well: https://developer.jboss.org/thread/276791

      Though I only tried 9.1.3 on Wildfly 10.1.0, the instructions seem to work fine with that version of Wildfly.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              silvaran Scott Van Wart (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: