Uploaded image for project: 'Infinispan'
  1. Infinispan
  2. ISPN-7506

Tests fail after upgrading Lucene version

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 9.0.0.CR2
    • Component/s: None
    • Labels:
      None

      Description

      Upgrading Lucene causes clash with the elasticsearch being used in tests:

      org.infinispan.test.integration.as (1)
      query.ElasticsearchIndexManagerIT
      java.lang.AssertionError: Version must be upgraded to [5.5.4] is still set to [5.5.2]
      at org.elasticsearch.Version.(Version.java:316)
      at org.infinispan.query.test.elasticsearch.ElasticSearchCluster$TestNode.(ElasticSearchCluster.java:59)
      at org.infinispan.query.test.elasticsearch.ElasticSearchCluster$ElasticSearchClusterBuilder.buildNode(ElasticSearchCluster.java:123)
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  gustavonalle Gustavo Fernandes
                  Reporter:
                  gustavonalle Gustavo Fernandes
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: