Uploaded image for project: 'Infinispan'
  1. Infinispan
  2. ISPN-1060

Avoid errors when starting from a 4.x configuration mentioning lazyDeserialization

    XMLWordPrintable

    Details

    • Type: Feature Request
    • Status: Closed (View Workflow)
    • Priority: Optional
    • Resolution: Rejected
    • Affects Version/s: 5.0.0.BETA2
    • Fix Version/s: 5.0.0.CR1
    • Component/s: Configuration
    • Labels:
      None

      Description

      The configuration element lazyDeserialization was renamed to storeAsBinary, and the programmatic configuration is able to deal with it via deprecation.
      When starting a CacheManager v.5b2 on such an older XML configuration mentioning the old attribute, Infinispan fails to start.

      It would be very nice to be able to maintain backwards compatibility, or in alternative to make sure the error message is very clear.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              vblagojevic Vladimir Blagojevic (Inactive)
              Reporter:
              sannegrinovero Sanne Grinovero
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: