Uploaded image for project: 'HAL'
  1. HAL
  2. HAL-830

Can not remove remote connector in messaging subsystem through web console

XMLWordPrintable

    • Icon: Feature Request Feature Request
    • Resolution: Done
    • Icon: Major Major
    • 2.8.10
    • None
    • None

      When you in web console in messaging subsytem in connections add remote connetor, then you cannot remove that connector through web console. The same problem is in domian mode.

      Unexpected HTTP response: 500
      
      Request
      {
          "factory-class" => "",
          "socket-binding" => "sb",
          "address" => [
              ("subsystem" => "messaging--activemq"),
              ("server" => "default"),
              ("remote-connector" => "test")
          ],
          "operation" => "remove"
      }
      
      Response
      
      Internal Server Error
      {
          "outcome" => "failed",
          "failure-description" => "WFLYCTL0030: No resource definition is registered for address [
          (\"subsystem\" => \"messaging--activemq\"),
          (\"server\" => \"default\"),
          (\"remote-connector\" => \"test\")
      ]",
          "rolled-back" => true,
          "response-headers" => {"process-state" => "reload-required"}
      }
      

      1.Run EAP 7.0.0 DR9 in standalone mode with standalone-full-ha profile
      2.In web console go to configuration,subsystem,messaging,default , connections, connector(remote)
      3.Add remote connector
      4.Try to remove remote connector

      The same problem is for all types of connectors (remote/in-vm/generic).

            hpehl@redhat.com Harald Pehl
            pcyprian_jira Patrik Cyprian (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated:
              Resolved: