Uploaded image for project: 'HAL'
  1. HAL
  2. HAL-1004

Inconsistent behaviour in admin console for filtered search in environment properties

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Done
    • 2.8.15
    • 2.8.17
    • Ballroom
    • None

    Description

      In admin console filter/search of system properties under the Runtime tab is not working as expected.

      Steps to Reproduce:

      a) start a latest WildFly in standalone mode
      
      b) login to Web Console 
      
      c) select tab Runtime -> Standalone Server ->  Environment -> View
      
      d) A paged view of all the properties is shown 
      
      e) If one performs a search from the first page a global search on all the properties is issued: => for example type “http” in the filter area
      
      f) if , on the other hand , one  selects a particular page =>for example page 2 (showing results from 9-16 of 90 ) and performs the same search (type “http” in the filter area ) one cannot see the results. It shows "9-9 of 1" as index beside my table. I have to click and switch back to page 1 to see the real result. Looks like it has the correct filtered result, but it does not update range to page 1 and it displays from page 2 which is empty page in this case.
      
      Same problem for table in Runtime -> Standalone Server ->  Log Files -> View
      

      reported in EAP https://bugzilla.redhat.com/show_bug.cgi?id=1286336

      Attachments

        Issue Links

          Activity

            People

              chaowan@redhat.com Chao Wang
              chaowan@redhat.com Chao Wang
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: