Uploaded image for project: 'Fuse Tooling'
  1. Fuse Tooling
  2. FUSETOOLS-2494

Auto-deployment and auto-compilation work almost randomly

    Details

    • Steps to Reproduce:
      Hide

      1) I create an application with Camel routes
      2) I compile and deploy it on Camel
      3) I add a space character into pom.xml and save it
      4) New version deploys automatically
      5) I leave the computer on for the night
      6) I add a space character into pom.xml and save it again
      7) Project does not compile. It tries to deploy, but as it has deleted Manifest and has not created, it gives an error that is correct, but difficult for beginners to understand: "missing or invalid Manifest"
      8) I restart Eclipse (and with Eclipse application servers as well)
      9) No changes
      10) I make mvn clean install
      11) Auto-deployment gets stuck and lasts for forever
      12) I uninstall and reinstall application
      13) I test. Ok.
      14) I add a space on pom.xml again
      15) Auto-deployment does not happen
      16) Wait for 10 minutes
      17) I add a space on pom.xml again
      18) Auto-deployment works again

      Show
      1) I create an application with Camel routes 2) I compile and deploy it on Camel 3) I add a space character into pom.xml and save it 4) New version deploys automatically 5) I leave the computer on for the night 6) I add a space character into pom.xml and save it again 7) Project does not compile. It tries to deploy, but as it has deleted Manifest and has not created, it gives an error that is correct, but difficult for beginners to understand: "missing or invalid Manifest" 8) I restart Eclipse (and with Eclipse application servers as well) 9) No changes 10) I make mvn clean install 11) Auto-deployment gets stuck and lasts for forever 12) I uninstall and reinstall application 13) I test. Ok. 14) I add a space on pom.xml again 15) Auto-deployment does not happen 16) Wait for 10 minutes 17) I add a space on pom.xml again 18) Auto-deployment works again

      Description

      One problem with auto-compilation and perhaps two problems with auto-deployment. See the steps.

      Error message about Manifest:

      !ENTRY org.fusesource.ide.server.karaf.core 4 4 2017-07-21 09:04:21.172
      !MESSAGE Deployment problem: Binary archive /home/perttu/workspace/.metadata/.plugins/org.fusesource.ide.server.karaf.core/JBoss_Fuse_6.3_Runtime_Server/tempRemoteDeploy/fuse-1.0.0-SNAPSHOT.jar is not valid or lacking a valid MANIFEST.MF!
      

      Error message that is probably irrelevant to the issue (I don't know what makes this):

      !ENTRY org.fusesource.ide.camel.model.service.core 2 0 2017-07-21 09:18:48.075
      !MESSAGE ParseAttributes: Unsupported EIP will be ignored: camelContext
      

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                timo.riikonen Timo Riikonen
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: