Uploaded image for project: 'AMQ Streams'
  1. AMQ Streams
  2. ENTMQST-3047

AMQ Streams Operator 1.7.2 is blocking the installation of other operators

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: 1.7.0.GA
    • Fix Version/s: 1.7.0.GA
    • Component/s: None
    • Labels:
      None
    • Steps to Reproduce:
      Hide
      1. Login to OCP 4.7
      2. Go to OperatorHub
      3. Install AMQ Streams Operator 1.7.2 in cluster mode
      4. Install another operator in cluster mode, e.g., Camel K Operator or Service Registry Operator 2.0
      5. The installation never completes
      6. Uninstall AMQ Streams Operator 1.7.2
      7. The blocked installation completes successfully
      Show
      Login to OCP 4.7 Go to OperatorHub Install AMQ Streams Operator 1.7.2 in cluster mode Install another operator in cluster mode, e.g., Camel K Operator or Service Registry Operator 2.0 The installation never completes Uninstall AMQ Streams Operator 1.7.2 The blocked installation completes successfully

      Description

      On OCP 4.7, AMQ Streams Operator 1.7.2 in cluster mode is blocking the installation of other operators in cluster mode.

      The following event was found:

      2m19s       Warning   ResolutionFailed                             namespace/openshift-operators        found multiple channel heads: [amqstreams.v1.7.2 amqstreams.v1.6.2], please check the `replaces`/`skipRange` fields of the operator bundles
      
      

        Attachments

          Activity

            People

            Assignee:
            kliberti Kyle Liberti
            Reporter:
            abrianik Alexandre Kieling
            Tester:
            Lukas Kral Lukas Kral
            Votes:
            0 Vote for this issue
            Watchers:
            10 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: