Uploaded image for project: 'AMQ Broker'
  1. AMQ Broker
  2. ENTMQBR-4441

[LTS-7.8] MBean context isn't switched properly

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Done
    • AMQ 7.8.0.GA
    • None
    • console
    • Workaround Exists
    • Hide
      # swap in the old console from 7.7 release
      
      AMQ78_HOME="/Users/fvaleri/cases/02827234/amq-broker-7.8.0"
      AMQ78_INST="/Users/fvaleri/cases/02827234/hosts/host0"
      AMQ77_HOME="/Users/fvaleri/cases/02827234/amq-broker-7.7.0"
      AMQ77_INST="/Users/fvaleri/cases/02827234/hosts/host1"
      
      tar czf backup-amq78-home.tar.gz $AMQ78_HOME
      tar czf backup-amq78-inst.tar.gz $AMQ78_INST
      
      mv $AMQ78_HOME/web $AMQ78_HOME/web.new
      mv $AMQ78_INST/etc/bootstrap.xml $AMQ78_INST/etc/bootstrap.xml.new
      
      cp -R $AMQ77_HOME/web $AMQ78_HOME/web
      cp $AMQ77_INST/etc/bootstrap.xml $AMQ78_INST/etc/bootstrap.xml
      
      Show
      # swap in the old console from 7.7 release AMQ78_HOME= "/Users/fvaleri/cases/02827234/amq-broker-7.8.0" AMQ78_INST= "/Users/fvaleri/cases/02827234/hosts/host0" AMQ77_HOME= "/Users/fvaleri/cases/02827234/amq-broker-7.7.0" AMQ77_INST= "/Users/fvaleri/cases/02827234/hosts/host1" tar czf backup-amq78-home.tar.gz $AMQ78_HOME tar czf backup-amq78-inst.tar.gz $AMQ78_INST mv $AMQ78_HOME/web $AMQ78_HOME/web. new mv $AMQ78_INST/etc/bootstrap.xml $AMQ78_INST/etc/bootstrap.xml. new cp -R $AMQ77_HOME/web $AMQ78_HOME/web cp $AMQ77_INST/etc/bootstrap.xml $AMQ78_INST/etc/bootstrap.xml
    • -

    Description

      When clicking attributes or operations, from the queues, addresses table view, it is not updating the context as it used to, as such the hierarchy tree is no longer expanded and selected the correct node in the hierarchy. It's not only the hierarchy not changing, but its the context, as such when we click operations, the operations are for a compleatly different mbean not the current context one of the queue we were on, like wise the additonal menu options for delete browse were not showing.

      Basically, the broker name isn't being escaped properly / handled correctly in the new console, breaking it. If you have broker name 0.0.0.0 it is fine because its not using any character that needs to be escaped. Whereas if you use broker name "bob-marley" it all breaks as the "-" isnt escaped handled correctly. Issues like this did exist in the old console but were fixed.

      The JavaScript in the table area is making the new URL but missing the broker's name parts after "-":

      # e.g. its making
      http://localhost:8161/console/artemis/attributes?tab=artemis&nid=root-org.apache.activemq.artemis-bob-addresses-DLQ-queues-anycast-DLQ
      
      # when the url should have been
      http://localhost:8161/console/artemis/attributes?tab=artemis&nid=root-org.apache.activemq.artemis-bob-marley-addresses-DLQ-queues-anycast-DLQ
      

      What's interesting is that the JavaScript in the tree hierarchy correctly handles this, and creates the correct URL on action.

      Tested connecting to remote broker with Microsoft Edge, Chrome and Firefox on Windows 10.

      Attachments

        Issue Links

          Activity

            People

              ataylor@redhat.com Andy Taylor
              dbruscin Domenico Francesco Bruscino
              Oleg Sushchenko Oleg Sushchenko
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: