Uploaded image for project: 'AMQ Broker'
  1. AMQ Broker
  2. ENTMQBR-3213

Failback does not work master/slave cluster using NFS shared store

    XMLWordPrintable

Details

    • Hide

      1- machine1, machine2
      2- NFS server running on machine1
      3- No firewall between machine1 and machine2
      4- NFS setup:
      machine1: mkdir /home/quicklab/nfsshare; mkdir /home/quicklab/data
      machine1: sudo mount -t nfs -o proto=tcp,sync,lookupcache=none,soft,timeo=20,retrans=2,intr <machine1>:/home/quicklab/nfsshare /home/quicklab/data
      <machine2>: mkdir /home/quicklab/data
      <machine2>: sudo mount -t nfs -o proto=tcp,sync,lookupcache=none,soft,timeo=20,retrans=2,intr <machine1>:/home/quicklab/nfsshare /home/quicklab/data

      5- create broker on machine1:
      bin/artemis create brokers/master2 --data /home/quicklab/data --failover-on-shutdown --name master --relax-jolokia --require-login --shared-store --user admin --password admin --host <machine1> --cluster-user admin --cluster-password admin --staticCluster "tcp://<machine1>:61616,tcp://<machine2>:61616"

      6- create broker on machine2:
      bin/artemis create brokers/slave2 --data /home/quicklab/data --failover-on-shutdown --name slave --relax-jolokia --require-login --shared-store --user admin --password admin --host <machine2> --cluster-user admin --cluster-password admin --slave --staticCluster "tcp://<machine1>:61616,tcp://<machine2>:61616"

      7- Manually add <allow-failback>true<allow-failback> to slave config
      8- Start master
      9- Start salve
      10- Ctrl+c master: slave get active
      11- restart master, fail-back does not happen

      same steps done with 7.4.1, fail-back happens.

      Show
      1- machine1, machine2 2- NFS server running on machine1 3- No firewall between machine1 and machine2 4- NFS setup: machine1: mkdir /home/quicklab/nfsshare; mkdir /home/quicklab/data machine1: sudo mount -t nfs -o proto=tcp,sync,lookupcache=none,soft,timeo=20,retrans=2,intr <machine1>:/home/quicklab/nfsshare /home/quicklab/data <machine2>: mkdir /home/quicklab/data <machine2>: sudo mount -t nfs -o proto=tcp,sync,lookupcache=none,soft,timeo=20,retrans=2,intr <machine1>:/home/quicklab/nfsshare /home/quicklab/data 5- create broker on machine1: bin/artemis create brokers/master2 --data /home/quicklab/data --failover-on-shutdown --name master --relax-jolokia --require-login --shared-store --user admin --password admin --host <machine1> --cluster-user admin --cluster-password admin --staticCluster "tcp://<machine1>:61616,tcp://<machine2>:61616" 6- create broker on machine2: bin/artemis create brokers/slave2 --data /home/quicklab/data --failover-on-shutdown --name slave --relax-jolokia --require-login --shared-store --user admin --password admin --host <machine2> --cluster-user admin --cluster-password admin --slave --staticCluster "tcp://<machine1>:61616,tcp://<machine2>:61616" 7- Manually add <allow-failback>true<allow-failback> to slave config 8- Start master 9- Start salve 10- Ctrl+c master: slave get active 11- restart master, fail-back does not happen same steps done with 7.4.1, fail-back happens.
    • Hide
      Previously, if you configured a live-backup broker group to use the shared store high availability (HA) policy with a Network File System (NFS), the backup broker did not fail back to the original live broker when the live broker became available again after a previous failure. This issue occurred even if you set `allow-failback` to `true` in the configuration of your backup broker. This issue is now resolved.
      Show
      Previously, if you configured a live-backup broker group to use the shared store high availability (HA) policy with a Network File System (NFS), the backup broker did not fail back to the original live broker when the live broker became available again after a previous failure. This issue occurred even if you set `allow-failback` to `true` in the configuration of your backup broker. This issue is now resolved.
    • Documented as Resolved Issue
    • -
    • Verified in a release

    Description

      Normal fail-back to master does not work on 7.5. used to work on 7.4.1.

      Attachments

        Issue Links

          Activity

            People

              ataylor@redhat.com Andy Taylor
              rhn-support-jsherman Jason Sherman
              Tiago Bueno Tiago Bueno
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: