Uploaded image for project: 'A-MQ Broker'
  1. A-MQ Broker
  2. ENTMQBR-2596

HA replication diagram does not remove (update) missing (killed) slaves in topology

    Details

    • Type: Bug
    • Status: New
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: AMQ 7.3.0.GA
    • Fix Version/s: None
    • Component/s: console, high-availability
    • Labels:
      None
    • Target Release:
    • Steps to Reproduce:
      1. Fire up 3 HA replication pairs
      2. Kill one slave
      3. Observe console behavior and displaying of slaves (is not updated)
      4. Repeat previous 2 steps

      Description

      When we have 3 HA pairs (which are properly distinguished by master/slave colors ENTMQBR-1700 fixed that), there is a problem with displaying properly slave nodes.

      I have killed 2 out of 3 slaves and they keep being displayed as active slaves for given masters. This is imo a bug.
      First I thought it's a bug in diagram only, but Howard Gao told me, that diagram now reflects the true nature of provided topology. Is that some kind of feature or bug?

      I think this is a bug.
      This was discovered while checking upstream PR for 7.4.0 from Howard Gao.
      https://issues.apache.org/jira/browse/ARTEMIS-2388

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  ataylor Andy Taylor
                  Reporter:
                  mtoth Michal Toth
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated: