Uploaded image for project: 'AMQ Broker'
  1. AMQ Broker
  2. ENTMQBR-2037

Message "AMQ151002: Reconnected with broker" is only logged if reconnect thread is run

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Explained
    • AMQ 7.1.0.GA
    • None
    • None
    • Hide

      Set up two JBoss instances

      • instance with destination
      • instance with MDB bound to remote JBoss instance
        Start both instances
        Confirm that there a consumer on destination in the remote JBoss instance
        Shutdown remote JBoss instance
        Restart remote JBoss Instance and confirm that there is a consumer on the destination
        Confirm that there is no message AMQ151002 in MDB hosting JBoss instance log
      Show
      Set up two JBoss instances instance with destination instance with MDB bound to remote JBoss instance Start both instances Confirm that there a consumer on destination in the remote JBoss instance Shutdown remote JBoss instance Restart remote JBoss Instance and confirm that there is a consumer on the destination Confirm that there is no message AMQ151002 in MDB hosting JBoss instance log

    Description

      It seems that the message "AMQ151002: Reconnected with broker" is only logged if a connection failure occurs during initial RA setup or during messaging handling. If a connection failure occurs if there is no message processing at all there no logging indicating that a connection has been reestablished.

      Attachments

        Activity

          People

            rhn-support-jbertram Justin Bertram
            rhn-support-toross Tom Ross
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: