Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-17890

Dependency version of springboot is missing in a particular integration build

    XMLWordPrintable

Details

    • Bug
    • Status: Done
    • Blocker
    • Resolution: Done
    • fuse-7.10-GA
    • fuse-7.10-GA
    • Fuse Online
    • None
    • False
    • False
    • % %
    • Todo

    Description

      The integration from the Documentation tutorials (AMQ->Extension->TODO) is not able to be built.

      During the testing of unreleased Fuse Online, the integration (AMQ->Extension->TODO from documentation) is not able to be built due to unreleased dependencies (more info in ENTESB-15809 ). To workaround that, we set our repositories in Syndesis cr

            server:
              features:
                maven:
                  append: true
                  repositories:
                    central: https://repo.maven.apache.org/maven2/
                    qe-repo: http://nexus.fuse-qe.eng.rdu2.redhat.com/repository/fuse-all
                    repo-02-redhat-ga: https://maven.repository.redhat.com/ga/
                    repo-03-jboss-ea: https://repository.jboss.org/nexus/content/groups/ea/
      

      and the integration works.(integration build log from AR7, where it was working is in the attachments)

      However, on AR9 build, the integration build fails on:

      [INFO] Error stacktraces are turned on.
      [INFO] Scanning for projects...
      [ERROR] [ERROR] Some problems were encountered while processing the POMs:
      [ERROR] 'dependencies.dependency.version' for org.springframework.boot:spring-boot-starter:jar is missing. @ line 130, column 17
       @
      [ERROR] The build could not read 1 project -> [Help 1]
      org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs:
      [ERROR] 'dependencies.dependency.version' for org.springframework.boot:spring-boot-starter:jar is missing. @ line 130, column 17
      
          at org.apache.maven.project.DefaultProjectBuilder.build (DefaultProjectBuilder.java:397)
          at org.apache.maven.graph.DefaultGraphBuilder.collectProjects (DefaultGraphBuilder.java:414)
          at org.apache.maven.graph.DefaultGraphBuilder.getProjectsForMavenReactor (DefaultGraphBuilder.java:405)
          at org.apache.maven.graph.DefaultGraphBuilder.build (DefaultGraphBuilder.java:82)
          at org.apache.maven.DefaultMaven.buildGraph (DefaultMaven.java:507)
          at org.apache.maven.DefaultMaven.doExecute (DefaultMaven.java:219)
          at org.apache.maven.DefaultMaven.doExecute (DefaultMaven.java:192)
          at org.apache.maven.DefaultMaven.execute (DefaultMaven.java:105)
          at org.apache.maven.cli.MavenCli.execute (MavenCli.java:956)
          at org.apache.maven.cli.MavenCli.doMain (MavenCli.java:288)
          at org.apache.maven.cli.MavenCli.main (MavenCli.java:192)
          at sun.reflect.NativeMethodAccessorImpl.invoke0 (Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke (NativeMethodAccessorImpl.java:62)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke (DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke (Method.java:498)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced (Launcher.java:282)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launch (Launcher.java:225)
          at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode (Launcher.java:406)
          at org.codehaus.plexus.classworlds.launcher.Launcher.main (Launcher.java:347)
      [ERROR]
      [ERROR]   The project io.syndesis.integrations:project:0.1-SNAPSHOT (/tmp/src/pom.xml) has 1 error
      [ERROR]     'dependencies.dependency.version' for org.springframework.boot:spring-boot-starter:jar is missing. @ line 130, column 17
      [ERROR]
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
      

      (It was not tested on AR8 due to OpenApi blocker )
      It works correctly on AR7

      Attachments

        Activity

          People

            zregvart-redhat Zoran Regvart
            mkralik@redhat.com Matej Kralik
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: