Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-17757

SSH client libraries incompatible with camel-ftp and camel-jsch

    XMLWordPrintable

Details

    • Bug
    • Status: Done
    • Blocker
    • Resolution: Done
    • None
    • fuse-7.10-GA
    • Camel
    • None

    Description

      Currently we have ...

      https://github.com/jboss-fuse/camel/blame/2.23.x.redhat-7-x/parent/pom.xml#L700

      <sshd-version>2.7.0.redhat-00001</sshd-version>
      <sshd-for-ftp-tests-version>2.5.1</sshd-for-ftp-tests-version>
      

      and indeed the ssh client libraries from 2.7.0 do not seem to work with camel-ftp and camel-jsch. Can we possibly consolidate this to one valid version? EAP-7.4.2 uses 2.7.0.redhat-00001 and this is also part of the compatibility contract (i.e. cannot be provided as alternative in the fuse layer).

      Attachments

        Issue Links

          Activity

            People

              jondruse@redhat.com Jiri Ondrusek
              tdiesler@redhat.com Thomas Diesler
              Branislav Smolicek Branislav Smolicek
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: