Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-17086

Can't upgrade from 1.3.3 to 1.4.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: Camel-K-GA
    • Component/s: Camel-K
    • Labels:
      None

      Description

      I am working on OCP 4.6. The operator upgrade stuck on 

      
      oc get csv                                        
      NAME                              DISPLAY                         VERSION   REPLACES                          PHASE
      red-hat-camel-k-operator.v1.3.3   Red Hat Integration - Camel K   1.3.3     red-hat-camel-k-operator.v1.3.2   Replacing
      red-hat-camel-k-operator.v1.4.0   Red Hat Integration - Camel K   1.4.0     red-hat-camel-k-operator.v1.3.3   Pending 
      
        - group: ""
          kind: ServiceAccount
          message: Service account is owned by another ClusterServiceVersion
          name: camel-k-operator
          status: PresentNotSatisfied
          version: v1 

        Attachments

          Activity

            People

            Assignee:
            stefanutti Antonin Stefanutti
            Reporter:
            jbouska Jan Bouska
            Tester:
            Mario Majernik Mario Majernik
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: