Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-16902

Missing API Connector review page when API contains error

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: fuse-7.9-GA
    • Fix Version/s: fuse-7.9-GA
    • Component/s: Fuse Online
    • Labels:
      None

      Description

      When the user review API via Apicurio, makes some changes (and accidently makes some mistake) which results in the error, when they save it, there is no review page with the error in Syndesis as before (AR15),

      reviewPageAR15.webm
      but the UI is gotten back to the first step with only modal dialog error.

      reviewPageAR16.webm

      So all changes, which were made in Apicurio, are gone and the user needs to import API and do changes again. In AR15, the user just click on Review and correct the mistake in Apicurio.

      This is probably the side effect of this issue: https://issues.redhat.com/browse/ENTESB-14078

        Attachments

        1. errorReviewAR15.png
          errorReviewAR15.png
          250 kB
        2. errorReviewAR16.png
          errorReviewAR16.png
          210 kB
        3. reviewPageAR15.webm
          5.75 MB
        4. reviewPageAR16.webm
          411 kB

          Issue Links

            Activity

              People

              Assignee:
              zregvart-redhat Zoran Regvart
              Reporter:
              mkralik@redhat.com Matej Kralik
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: