Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-16804

Installation via OperatorHub probably uses the old CRD

    XMLWordPrintable

Details

    • Bug
    • Status: Done
    • Blocker
    • Resolution: Done
    • fuse-7.9-GA
    • fuse-7.9-GA
    • Fuse Online
    • None
    • Todo

    Description

      When I install Syndesis via OperatorHub (image fuse7-fuse-online-rhel8-operator-metadata:1.9-7) , the operator contains the following error when I create Syndesis CR

      {"level":"error","ts":1624273434.0784473,"logger":"controller","msg":"Error reconciling","action":"*action.initializeAction","phase":"","error":"syndesises.syndesis.io \"app\" not found
      

      parichar@redhat.com I remember that we have been facing with the similar issue when the old CRD was used with the new operator so it looks that the installation via OperatorHub uses old CRD.
      I also noticed (when I compare rhel7 and rhel8 branches) that rhel8 branch contains some old syndesis.crd.yaml https://github.com/jboss-fuse/fuse-online-operator-prod-operator-metadata/tree/fuse-7.9-openshift-rhel-8/manifests .

      Installation via install-script / operator works correctly.

      Attachments

        Activity

          People

            parichar@redhat.com Paul Richardson
            mkralik@redhat.com Matej Kralik
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: