Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-15689

Fuse 7.9 should use Undertow 2.0 whether or not it's aligned to EAP 7.4

    XMLWordPrintable

Details

    • Task
    • Status: Open
    • Major
    • Resolution: Unresolved
    • None
    • None
    • None
    • None

    Description

      EAP 7.4 uses Undertow 2.2.x. Since UNDERTOW-1684, Undertow does not support OSGi at all.
      Fuse-Karaf flavor of Fuse 7 product is OSGi based platform and proper OSGi bundle manifests are crucial to it's operation.

      Whether or not Fuse 7.9 will align to EAP 7.4, Fuse-Karaf part of entire product should continue to use supported version of Undertow 2.0.x.

      It'd be no problem for me to bring back OSGi support to Undertow 2.1+ - especially because I see no linked document that'd justify such removal.
      I have no problems with WFLY-1638 which concerns "JBoss OSGi" in general, but Undertow component itself being used not only in EAP/Wildfly should keep OSGi support - especially because Fuse 7 made such critical decision to switch from Jetty to Undertow.

      /cc: acunning@redhat.com, janstey@redhat.com, gmalinko, drieden@redhat.com, garygaughan, yfang@redhat.com.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              ggrzybek Grzegorz Grzybek
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated: