Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-15232

Fuse Operators don't show up after upgrading to OCP 4.6

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Explained
    • None
    • fuse-7.8-GA
    • None
    • None

    Description

      This issue is caused by a problem within Openshift itself. It's document here:
       
      https://bugzilla.redhat.com/show_bug.cgi?id=1891993 
      https://bugzilla.redhat.com/show_bug.cgi?id=1891995

      Workaround

      I had to force a refresh of the Operatorhub to get the correct listings. We might want to add a release note.

      I was still presented only with the `alpha` channel when creating a new subscription. This can be resolved by running

      oc patch operatorhub/cluster --type=merge -p '"spec": {"disableAllDefaultSources": true}'
      
      

      Wait until operatorhub lists no sources/only custom sources and run:

      oc patch operatorhub/cluster --type=merge -p '"spec": {"disableAllDefaultSources": false}'
      
      

       

      This should force the reload of all catalogs and the fuse-product.7.7.x channel will show up.

       

      Attachments

        Activity

          People

            Unassigned Unassigned
            rhn-support-hbraun Heiko Braun
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: