Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-15065

fabric8-maven-plugin error applying RoleBinding

    XMLWordPrintable

Details

    • build6

    Description

       

      Splitting this out from ENTESB-14419 - smongiar reports an issue deploying spring-boot-camel-config that also affects spring-boot-camel-rest-3scale and possibly spring-boot-camel-xa.

       

      [ERROR] F8: Failed to create RoleBinding from openshift.yml. io.fabric8.kubernetes.client.KubernetesClientException: Failure executing: POST at: https://api.foo-45ga-a.dos.fuse-qe.eng.rdu2.redhat.com:6443/api/v1/namespaces/fuse7/rolebindings. Message: the server could not find the requested resource. Received status: Status(apiVersion=v1, code=404, details=StatusDetails(causes=[], group=null, kind=null, name=null, retryAfterSeconds=null, uid=null, additionalProperties={}), kind=Status, message=the server could not find the requested resource, metadata=ListMeta(_continue=null, remainingItemCount=null, resourceVersion=null, selfLink=null, additionalProperties={}), reason=NotFound, status=Failure, additionalProperties={}).: io.fabric8.kubernetes.client.KubernetesClientException: Failure executing: POST at: https://api.foo-45ga-a.dos.fuse-qe.eng.rdu2.redhat.com:6443/api/v1/namespaces/fuse7/rolebindings. Message: the server could not find the requested resource. Received status: Status(apiVersion=v1, code=404, details=StatusDetails(causes=[], group=null, kind=null, name=null, retryAfterSeconds=null, uid=null, additionalProperties={}), kind=Status, message=the server could not find the requested resource, metadata=ListMeta(_continue=null, remainingItemCount=null, resourceVersion=null, selfLink=null, additionalProperties={}), reason=NotFound, status=Failure, additionalProperties={}).
      

       

      I'm able to reproduce this with the 1.7 and the 1.8 fuse-java-openshift images, which means it probably is related to our fabric8-maven-plugin/kubernetes-client upgrades.   

       

      I think this has to do with https://github.com/fabric8-quickstarts/spring-boot-camel-config/blob/fuse-7.7.x.sb2.redhat/src/main/fabric8/rb.yml - most of the quickstarts do not have fragments like this.    

      Attachments

        Activity

          People

            yfang@redhat.com Freeman(Yue) Fang
            tcunning@redhat.com Thomas Cunningham
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: