Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-14443

Fuse 7.7 CodeReady studio quickstart for Karaf uses wrong BOM version

    XMLWordPrintable

Details

    Description

      Building the "Content Based Router - Blueprint DSL" example for Apache Karaf in CodeReady Studio fails, because the project references the wrong BOM version for Karaf. In particular, the quickstart POM contains these lines:

        <dependencyManagement>
          <dependencies>
            <dependency>
              <groupId>org.jboss.redhat-fuse</groupId>
              <artifactId>fuse-karaf-bom</artifactId>
              <version>7.8.0.fuse-sb2-780006</version>
              <type>pom</type>
              <scope>import</scope>
            </dependency>
          </dependencies>
        </dependencyManagement>
      

      Instead of referencing a Fuse 7.7 Karaf version, it's referencing a Fuse 7.8 Spring Boot 2 version.

      Attachments

        Activity

          People

            lheinema@redhat.com Lars Heinemann
            fbolton@redhat.com Fintan Bolton
            Dominik Jelínek Dominik Jelínek
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: