Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-12961

[Hawtio] No error message of creation endpoint with wrong URI in some cases

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: fuse-7.6-CR1
    • Fix Version/s: fuse-7.7-GA
    • Component/s: Hawtio, Karaf, Spring Boot
    • Labels:
      None
    • Prod build version:
      fuse-7.7-build1
    • Steps to Reproduce:
      Hide
      1. Run Fuse on Karaf or Spring Boot
      2. Open Hawtio
      3. Go to Camel Camel Contexts (for instance, cbr) -> Endpoints (folder) -> Endpoints (tab)
      4. Click on Add -> From URI
      5. Type, for instance, testfail
      6. You will see Creating endpoint message and no Error message and, obviously, Success message
      Show
      Run Fuse on Karaf or Spring Boot Open Hawtio Go to Camel Camel Contexts (for instance, cbr) -> Endpoints (folder) -> Endpoints (tab) Click on Add -> From URI Type, for instance, testfail You will see Creating endpoint message and no Error message and, obviously, Success message

      Description

      There is no Error message when you create an endpoint with wrong URI of testfail.
      There is only Creating endpoint message.
      View the video attached.

      However, if you try to create the endpoint from URI of https://testfail_ - it shows the _Error message as it is supposed.

        Attachments

          Activity

            People

            Assignee:
            alexkieling Alexandre Kieling
            Reporter:
            jsolovjo Juri Solovjov
            Tester:
            Dusan Uradnik Dusan Uradnik
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: