Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-12550

Unable to install feature camel-rest-swagger

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Blocker
    • Resolution: Done
    • fuse-7.6-GA
    • fuse-7.6-ER1
    • Karaf
    • None
    • % %
      • bin/fuse
      • feature:install camel-rest-swagger

    Description

      Hello, there is a problem installing feature camel-rest-swagger:

      2019-12-17 11:53:27,439 | INFO  | l camel-rest-swagger | o.a.k.f.i.s.FeaturesServiceImpl  | 13 - org.apache.karaf.features.core - 4.2.6.fuse-760021 | Adding features: camel-rest-swagger/[2.21.0.fuse-760016,2.21.0.fuse-760016]
      2019-12-17 11:53:30,776 | ERROR | l console user karaf | o.a.k.s.s.ShellUtil              | 149 - org.apache.karaf.shell.core - 4.2.6.fuse-760021 | Exception caught while executing command
      org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=camel-rest-swagger; type=karaf.feature; version="[2.21.0.fuse-760016,2.21.0.fuse-760016]"; filter:="(&(osgi.identity=camel-rest-swagger)(type=karaf.feature)(version>=2.21.0.fuse-760016)(version<=2.21.0.fuse-760016))" [caused by: Unable to resolve camel-rest-swagger/2.21.0.fuse-760016: missing requirement [camel-rest-swagger/2.21.0.fuse-760016] osgi.identity; osgi.identity=org.apache.camel.camel-rest-swagger; type=osgi.bundle; version="[2.21.0.fuse-760016,2.21.0.fuse-760016]"; resolution:=mandatory [caused by: Unable to resolve org.apache.camel.camel-rest-swagger/2.21.0.fuse-760016: missing requirement [org.apache.camel.camel-rest-swagger/2.21.0.fuse-760016] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.camel.component.http4)(version>=2.21.0)(!(version>=2.22.0)))"]]
      	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343) ~[?:?]
      	at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392) ~[?:?]
      	at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378) ~[?:?]
      	at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332) ~[?:?]
      	at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257) ~[?:?]
      	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393) ~[?:?]
      	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062) ~[?:?]
      	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998) ~[?:?]
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:1.8.0_191]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) ~[?:1.8.0_191]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) ~[?:1.8.0_191]
      	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_191]
      Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve camel-rest-swagger/2.21.0.fuse-760016: missing requirement [camel-rest-swagger/2.21.0.fuse-760016] osgi.identity; osgi.identity=org.apache.camel.camel-rest-swagger; type=osgi.bundle; version="[2.21.0.fuse-760016,2.21.0.fuse-760016]"; resolution:=mandatory [caused by: Unable to resolve org.apache.camel.camel-rest-swagger/2.21.0.fuse-760016: missing requirement [org.apache.camel.camel-rest-swagger/2.21.0.fuse-760016] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.camel.component.http4)(version>=2.21.0)(!(version>=2.22.0)))"]
      	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343) ~[?:?]
      	... 12 more
      Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve org.apache.camel.camel-rest-swagger/2.21.0.fuse-760016: missing requirement [org.apache.camel.camel-rest-swagger/2.21.0.fuse-760016] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.camel.component.http4)(version>=2.21.0)(!(version>=2.22.0)))"
      	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343) ~[?:?]
      	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343) ~[?:?]
      	... 12 more
      

      Attachments

        Activity

          People

            yfang@redhat.com Freeman(Yue) Fang
            vhais Vratislav Hais
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: