Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-11541

Support OpenAPI 3.0

    XMLWordPrintable

Details

    • % %
    • +
    • Automated
    • 18

    Description

      (Migrated from https://github.com/syndesisio/syndesis/issues/467)

      Author: Zoran Regvart
      Assignees: unassigned
      We currently have support for Swagger 2.0 in the API connector (client) API Provider and Apicurito standalone, we should also support OpenAPI 3.0 for all.
      We should continue to support 2.0 and respect that format.
      We should test the roundtrip of an import, export and subsequent import again.
      We should ensure that active docs in 3scale also continues to display correctly.

      Questions:
      Is OpenAPI 3.0 supported in Camel?

      Epic Brief: https://docs.google.com/document/d/1iL3Fchb1anhrueUjMQfBARDpCpwlqRGjBXj6dPzLuSk/edit?usp=sharing

      Attachments

        Issue Links

          Activity

            People

              christoph.deppisch Christoph Deppisch
              zregvart-redhat Zoran Regvart
              Martin Muzikar Martin Muzikar
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: