Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-11485

Add guidelines to the templates about which version should be used where

    XMLWordPrintable

Details

    • % %
    • ?

    Description

      (Migrated from https://github.com/syndesisio/syndesis/issues/4136)

      Author: Andrej Va┼ło
      Assignees: unassigned

      This is a...

      [pre][code]
      [X] Feature request
      [ ] Regression (a behavior that used to work and stopped working in a new release)
      [ ] Bug report [!-- Please search GitHub for a similar issue or PR before submitting --]
      [ ] Documentation issue or request
      [/code][/pre]

      Description

      Based on the email conversation, here is the summary I did about which version should be used where:

      ``

      For 7.2 we have:
      SYNDESIS_UPSTREAM=1.5
      SYNDESIS_PROD=1.2
      
      I took the templates from both images and substituted correct variables, here are the lines:
      
      OPERATOR:
      https://gist.github.com/avano/f250e4fa49833689e4af659032059ef7#file-operator-versions-L8
      https://gist.github.com/avano/f250e4fa49833689e4af659032059ef7#file-operator-versions-L200
      https://gist.github.com/avano/f250e4fa49833689e4af659032059ef7#file-operator-versions-L316
      https://gist.github.com/avano/f250e4fa49833689e4af659032059ef7#file-operator-versions-L813
      https://gist.github.com/avano/f250e4fa49833689e4af659032059ef7#file-operator-versions-L1144
      https://gist.github.com/avano/f250e4fa49833689e4af659032059ef7#file-operator-versions-L1209
      
      UPGRADE:
      https://gist.github.com/avano/b6c7f8f2ea7faae7a0de148206135279#file-upgrade-versions-L7
      https://gist.github.com/avano/b6c7f8f2ea7faae7a0de148206135279#file-upgrade-versions-L199
      https://gist.github.com/avano/b6c7f8f2ea7faae7a0de148206135279#file-upgrade-versions-L315
      https://gist.github.com/avano/b6c7f8f2ea7faae7a0de148206135279#file-upgrade-versions-L812
      https://gist.github.com/avano/b6c7f8f2ea7faae7a0de148206135279#file-upgrade-versions-L1143
      https://gist.github.com/avano/b6c7f8f2ea7faae7a0de148206135279#file-upgrade-versions-L1208
      + syndesis upgrade container should have system property SYNDESIS_VERSION property defined that resolves to [SYNDESIS_PROD]
      

      ``

      Attachments

        Activity

          People

            Unassigned Unassigned
            rhn-support-hbraun Heiko Braun
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: