Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-11419

Advanced filter expression is not saving

    XMLWordPrintable

Details

    • +
    • Automated

    Description

      (Migrated from https://github.com/syndesisio/syndesis/issues/5604)

      Author: Martin Muzikar
      Assignees: Stan Lewis,

      This is a...

      [pre][code]
      [ ] Feature request
      [x] Regression (a behavior that used to work and stopped working in a new release)
      [x] Bug report [!-- Please search GitHub for a similar issue or PR before submitting --]
      [ ] Documentation issue or request
      [/code][/pre]

      Description

      The advanced filter step is not saving the expression, or every time the user clicks on configure of that step, the expression is cleared.

      Steps to reproduce:
      1. start creating an integration
      2. start step can be timer
      3. finish step can be log
      4. add advanced filter between timer and log
      5. write some expression in the textarea and click on done
      6. click on the configure button of advanced filter

      If this is caused because the user inputs nonsense, it should be handled by error messages. Also I am curious if it's intended behavior to have advanced filter available even though there is no data in the integration I am using to describe the bug.

      Attachments

        Activity

          People

            rhn-support-hbraun Heiko Braun
            rhn-support-hbraun Heiko Braun
            Martin Muzikar Martin Muzikar
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: