Uploaded image for project: 'Drools'
  1. Drools
  2. DROOLS-6650

kie-karaf-itests test failures in 7.59.x

    XMLWordPrintable

Details

    • 2021 Week 40-42 (from Oct 4)
    • 2
    • NEW
    • NEW
    • ---
    • ---

    Description

      [INFO] Running org.kie.karaf.itest.camel.kiecamel.KieCamelRemoteIntegrationTest
      10:57:43.471 [main] INFO  o.k.k.i.AbstractKarafIntegrationTest.getKarafDistributionOption:179 - *** The karaf version is 4.3.2 ***
      10:57:43.472 [main] INFO  o.k.k.i.AbstractKarafIntegrationTest.getKarafDistributionOption:180 - *** The cxf version is 3.3.9 ***
      10:57:43.472 [main] INFO  o.k.k.i.AbstractKarafIntegrationTest.getKarafDistributionOption:181 - *** The camel version is 2.24.0 ***
      10:57:43.473 [main] INFO  o.k.k.i.AbstractKarafIntegrationTest.getFeaturesUrl:296 - Features URL: mvn:org.kie/kie-karaf-features/7.59.1-SNAPSHOT/xml/features
      WireMock server started and bound to localhost:59400
      org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=kie-camel; type=karaf.feature; version="[7.59.1.SNAPSHOT,7.59.1.SNAPSHOT]"; filter:="(&(osgi.identity=kie-camel)(type=karaf.feature)(version>=7.59.1.SNAPSHOT)(version<=7.59.1.SNAPSHOT))" [caused by: Unable to resolve kie-camel/7.59.1.SNAPSHOT: missing requirement [kie-camel/7.59.1.SNAPSHOT] osgi.identity; osgi.identity=org.kie.camel; type=osgi.bundle; version="[7.59.1.202110101132,7.59.1.202110101132]"; resolution:=mandatory [caused by: Unable to resolve org.kie.camel/7.59.1.202110101132: missing requirement [org.kie.camel/7.59.1.202110101132] osgi.wiring.package; filter:="(osgi.wiring.package=org.kie.server.client)" [caused by: Unable to resolve org.kie.server.client/7.59.1.202110101132: missing requirement [org.kie.server.client/7.59.1.202110101132] osgi.wiring.package; filter:="(osgi.wiring.package=org.wildfly.security.auth.server)"]]]
              at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1341)
              at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:433)
              at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:420)
              at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:374)
              at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
              at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:399)
              at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1069)
              at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:1004)
              at java.util.concurrent.FutureTask.run(FutureTask.java:266)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
              at java.lang.Thread.run(Thread.java:748)
      Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve kie-camel/7.59.1.SNAPSHOT: missing requirement [kie-camel/7.59.1.SNAPSHOT] osgi.identity; osgi.identity=org.kie.camel; type=osgi.bundle; version="[7.59.1.202110101132,7.59.1.202110101132]"; resolution:=mandatory [caused by: Unable to resolve org.kie.camel/7.59.1.202110101132: missing requirement [org.kie.camel/7.59.1.202110101132] osgi.wiring.package; filter:="(osgi.wiring.package=org.kie.server.client)" [caused by: Unable to resolve org.kie.server.client/7.59.1.202110101132: missing requirement [org.kie.server.client/7.59.1.202110101132] osgi.wiring.package; filter:="(osgi.wiring.package=org.wildfly.security.auth.server)"]]
              at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1341)
              ... 12 more
      Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve org.kie.camel/7.59.1.202110101132: missing requirement [org.kie.camel/7.59.1.202110101132] osgi.wiring.package; filter:="(osgi.wiring.package=org.kie.server.client)" [caused by: Unable to resolve org.kie.server.client/7.59.1.202110101132: missing requirement [org.kie.server.client/7.59.1.202110101132] osgi.wiring.package; filter:="(osgi.wiring.package=org.wildfly.security.auth.server)"]
              at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1341)
              ... 13 more
      Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve org.kie.server.client/7.59.1.202110101132: missing requirement [org.kie.server.client/7.59.1.202110101132] osgi.wiring.package; filter:="(osgi.wiring.package=org.wildfly.security.auth.server)"
              at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1341)
              ... 14 more
      [ERROR] Tests run: 2, Failures: 0, Errors: 2, Skipped: 0, Time elapsed: 181.791 s <<< FAILURE! - in org.kie.karaf.itest.camel.kiecamel.KieCamelRemoteIntegrationTest
      [ERROR] org.kie.karaf.itest.camel.kiecamel.KieCamelRemoteIntegrationTest  Time elapsed: 181.791 s  <<< ERROR!
      java.lang.RuntimeException: Cannot get the remote bundle context
      Caused by: java.rmi.NotBoundException: 508cd5fd-4864-436d-bfbb-8e73325962c3
      
      [ERROR] org.kie.karaf.itest.camel.kiecamel.KieCamelRemoteIntegrationTest  Time elapsed: 181.791 s  <<< ERROR!
      java.lang.RuntimeException: Container never came up
      

      Attachments

        Activity

          People

            rhn-support-tkobayas Toshiya Kobayashi
            rhn-support-tkobayas Toshiya Kobayashi
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: