Uploaded image for project: 'Drools'
  1. Drools
  2. DROOLS-6369

Fix kie-karaf-itests failures because of guava upgrade

    XMLWordPrintable

    Details

    • Sprint:
      2021 Week 19-21 (from May 10)
    • Story Points:
      2
    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      After https://github.com/kiegroup/droolsjbpm-build-bootstrap/pull/1620 , kie-karaf-itests fails with the errors:

      [2021-05-24T04:57:09.044Z] [INFO] Running org.kie.karaf.itest.blueprint.KieBlueprintDependencyKarafIntegrationTest
      [2021-05-24T04:57:09.618Z] 00:57:09.306 [main] INFO  o.k.k.i.AbstractKarafIntegrationTest.<clinit>:131 - KIE Project Version : 7.55.0-SNAPSHOT
      [2021-05-24T04:57:09.618Z] 00:57:09.330 [main] INFO  o.k.k.i.AbstractKarafIntegrationTest.getKarafDistributionOption:179 - *** The karaf version is 4.2.3 ***
      [2021-05-24T04:57:09.618Z] 00:57:09.331 [main] INFO  o.k.k.i.AbstractKarafIntegrationTest.getKarafDistributionOption:180 - *** The cxf version is 3.2.14 ***
      [2021-05-24T04:57:09.618Z] 00:57:09.331 [main] INFO  o.k.k.i.AbstractKarafIntegrationTest.getKarafDistributionOption:181 - *** The camel version is 2.21.5 ***
      [2021-05-24T04:57:09.618Z] 00:57:09.346 [main] INFO  o.k.k.i.AbstractKarafIntegrationTest.getFeaturesUrl:294 - Features URL: mvn:org.kie/kie-karaf-features/7.55.0-SNAPSHOT/xml/features
      [2021-05-24T04:57:21.942Z] org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=kie-aries-blueprint; type=karaf.feature; version="[7.55.0.SNAPSHOT,7.55.0.SNAPSHOT]"; filter:="(&(osgi.identity=kie-aries-blueprint)(type=karaf.feature)(version>=7.55.0.SNAPSHOT)(version<=7.55.0.SNAPSHOT))" [caused by: Unable to resolve kie-aries-blueprint/7.55.0.SNAPSHOT: missing requirement [kie-aries-blueprint/7.55.0.SNAPSHOT] osgi.identity; osgi.identity=jbpm-human-task; type=karaf.feature; version="[7.55.0.SNAPSHOT,7.55.0.SNAPSHOT]" [caused by: Unable to resolve jbpm-human-task/7.55.0.SNAPSHOT: missing requirement [jbpm-human-task/7.55.0.SNAPSHOT] osgi.identity; osgi.identity=org.jbpm.services.task.audit; type=osgi.bundle; version="[7.55.0.202105240137,7.55.0.202105240137]"; resolution:=mandatory [caused by: Unable to resolve org.jbpm.services.task.audit/7.55.0.202105240137: missing requirement [org.jbpm.services.task.audit/7.55.0.202105240137] osgi.wiring.package; filter:="(osgi.wiring.package=com.google.common.cache)" [caused by: Unable to resolve com.google.guava/30.0.0.jre: missing requirement [com.google.guava/30.0.0.jre] osgi.wiring.package; filter:="(&(osgi.wiring.package=com.google.common.util.concurrent.internal)(version>=1.0.0)(!(version>=2.0.0)))"]]]]
      [2021-05-24T04:57:21.942Z]      at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
      [2021-05-24T04:57:21.942Z]      at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
      [2021-05-24T04:57:21.942Z]      at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
      [2021-05-24T04:57:21.942Z]      at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
      [2021-05-24T04:57:21.942Z]      at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
      [2021-05-24T04:57:21.942Z]      at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:388)
      [2021-05-24T04:57:21.943Z]      at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1058)
      [2021-05-24T04:57:21.943Z]      at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:994)
      [2021-05-24T04:57:21.943Z]      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      [2021-05-24T04:57:21.943Z]      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
      [2021-05-24T04:57:21.943Z]      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
      [2021-05-24T04:57:21.943Z]      at java.lang.Thread.run(Thread.java:748)
      [2021-05-24T04:57:21.943Z] Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve kie-aries-blueprint/7.55.0.SNAPSHOT: missing requirement [kie-aries-blueprint/7.55.0.SNAPSHOT] osgi.identity; osgi.identity=jbpm-human-task; type=karaf.feature; version="[7.55.0.SNAPSHOT,7.55.0.SNAPSHOT]" [caused by: Unable to resolve jbpm-human-task/7.55.0.SNAPSHOT: missing requirement [jbpm-human-task/7.55.0.SNAPSHOT] osgi.identity; osgi.identity=org.jbpm.services.task.audit; type=osgi.bundle; version="[7.55.0.202105240137,7.55.0.202105240137]"; resolution:=mandatory [caused by: Unable to resolve org.jbpm.services.task.audit/7.55.0.202105240137: missing requirement [org.jbpm.services.task.audit/7.55.0.202105240137] osgi.wiring.package; filter:="(osgi.wiring.package=com.google.common.cache)" [caused by: Unable to resolve com.google.guava/30.0.0.jre: missing requirement [com.google.guava/30.0.0.jre] osgi.wiring.package; filter:="(&(osgi.wiring.package=com.google.common.util.concurrent.internal)(version>=1.0.0)(!(version>=2.0.0)))"]]]
      [2021-05-24T04:57:21.943Z]      at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
      [2021-05-24T04:57:21.943Z]      ... 12 more
      [2021-05-24T04:57:21.943Z] Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve jbpm-human-task/7.55.0.SNAPSHOT: missing requirement [jbpm-human-task/7.55.0.SNAPSHOT] osgi.identity; osgi.identity=org.jbpm.services.task.audit; type=osgi.bundle; version="[7.55.0.202105240137,7.55.0.202105240137]"; resolution:=mandatory [caused by: Unable to resolve org.jbpm.services.task.audit/7.55.0.202105240137: missing requirement [org.jbpm.services.task.audit/7.55.0.202105240137] osgi.wiring.package; filter:="(osgi.wiring.package=com.google.common.cache)" [caused by: Unable to resolve com.google.guava/30.0.0.jre: missing requirement [com.google.guava/30.0.0.jre] osgi.wiring.package; filter:="(&(osgi.wiring.package=com.google.common.util.concurrent.internal)(version>=1.0.0)(!(version>=2.0.0)))"]]
      [2021-05-24T04:57:21.943Z]      at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
      [2021-05-24T04:57:21.943Z]      ... 13 more
      [2021-05-24T04:57:21.943Z] Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve org.jbpm.services.task.audit/7.55.0.202105240137: missing requirement [org.jbpm.services.task.audit/7.55.0.202105240137] osgi.wiring.package; filter:="(osgi.wiring.package=com.google.common.cache)" [caused by: Unable to resolve com.google.guava/30.0.0.jre: missing requirement [com.google.guava/30.0.0.jre] osgi.wiring.package; filter:="(&(osgi.wiring.package=com.google.common.util.concurrent.internal)(version>=1.0.0)(!(version>=2.0.0)))"]
      [2021-05-24T04:57:21.943Z]      at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
      [2021-05-24T04:57:21.943Z]      ... 14 more
      [2021-05-24T04:57:21.943Z] Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve com.google.guava/30.0.0.jre: missing requirement [com.google.guava/30.0.0.jre] osgi.wiring.package; filter:="(&(osgi.wiring.package=com.google.common.util.concurrent.internal)(version>=1.0.0)(!(version>=2.0.0)))"
      [2021-05-24T04:57:21.943Z]      at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
      [2021-05-24T04:57:21.943Z]      ... 15 more
      [2021-05-24T05:00:13.631Z] [ERROR] Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 181.692 s <<< FAILURE! - in org.kie.karaf.itest.blueprint.KieBlueprintDependencyKarafIntegrationTest
      

        Attachments

          Activity

            People

            Assignee:
            tkobayashi Toshiya Kobayashi
            Reporter:
            tkobayashi Toshiya Kobayashi
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: