Uploaded image for project: 'Drools'
  1. Drools
  2. DROOLS-5388

Eclipse Rule Editor does not recognize Java source level

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 7.36.0.Final
    • Fix Version/s: None
    • Component/s: eclipse plugin
    • Labels:
      None
    • Steps to Reproduce:
      Hide
      1. Using the Eclipse Installer, install Eclipse for Java and DSL developers 2020-03 or 2020-06.
      2. Then install the org.drools.eclipse plugin from https://download.jboss.org/drools/release/7.36.0.Final/org.drools.updatesite/
      3. Create a new Drools Project (File > New > Project > Drools Project) and select the option to generate the project using sample files.
      4. Open drools-test/src/main/resources/com/sample/rules/Sample.drl in the Rule Editor.
      5. To the then block add the following line of code and save the file:

      Stream.of(m).forEach(System.out::println);

      Expected: no error marker appears

      Observed: error marker appears saying the lambdas can only be used in source level 1.8+

      Show
      Using the Eclipse Installer, install Eclipse for Java and DSL developers 2020-03 or 2020-06. Then install the org.drools.eclipse plugin from https://download.jboss.org/drools/release/7.36.0.Final/org.drools.updatesite/ Create a new Drools Project (File > New > Project > Drools Project) and select the option to generate the project using sample files. Open drools-test/src/main/resources/com/sample/rules/Sample.drl in the Rule Editor. To the then block add the following line of code and save the file: Stream.of(m).forEach(System.out::println); Expected: no error marker appears Observed: error marker appears saying the lambdas can only be used in source level 1.8+
    • Docs QE Status:
      NEW
    • QE Status:
      NEW
    • Stackoverflow ID:
      62062516

      Description

      See this stackoverflow:

      https://stackoverflow.com/q/62062516/2239897

      In an Eclipse 2020-03 or 2020-06 installation, when the org.drools.eclipse 7.36.0.Final plugin is installed, a .drl file containing Java 1.5+ source code shows error markers about unsupported Java syntax.

      Plugin org.drools.eclipse version 7.21.0.Final with an otherwise identical Eclipse installation works fine. There seems to be a regression introduced somewhere between 7.21.0 and 7.36.0.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                KrisVerlaenen Kris Verlaenen
                Reporter:
                xpomul33 Stefan Winkler
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: