Uploaded image for project: 'Debezium'
  1. Debezium
  2. DBZ-5404

Upgrade to Kafka 3.1 broke build compatibility with Kafka 2.x and Kafka 3.0

    XMLWordPrintable

Details

    Description

      The internal CI environment tests the build against Kafka 2.x and after applying the upgrade to Kafka 3.1 in DBZ-4610, the compatibility job fails:

      [ERROR] </debezium-kafka-2.x-test/ws/debezium-core/src/test/java/io/debezium/kafka/KafkaServer.java>:[22,17] cannot find symbol
      [ERROR]   symbol:   class UnifiedLog
      [ERROR]   location: package kafka.log
      [ERROR] </debezium-kafka-2.x-test/ws/debezium-core/src/test/java/io/debezium/kafka/KafkaServer.java>:[241,108] cannot find symbol
      [ERROR]   symbol:   variable UnifiedLog
      [ERROR]   location: class io.debezium.kafka.KafkaServer
      

      Attachments

        Activity

          People

            ccranfor@redhat.com Chris Cranford
            ccranfor@redhat.com Chris Cranford
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: