Uploaded image for project: 'Debezium'
  1. Debezium
  2. DBZ-4937

Debezium Server 1.9 Fails to start up when transferring 1.8 offsets

XMLWordPrintable

    • False
    • None
    • False
    • Hide

      1) Start Debezium Server 1.8 and then stop
      2) Copy data folder (including offsets.dat) to a 1.9CR1 instance
      3) Start up 1.9CR1
      4) Stop 1.9CR1
      5) Start 1.9CR1 again

      Show
      1) Start Debezium Server 1.8 and then stop 2) Copy data folder (including offsets.dat) to a 1.9CR1 instance 3) Start up 1.9CR1 4) Stop 1.9CR1 5) Start 1.9CR1 again

      Hi there,

      I've picked up an issue when trying to use an offsets.dat file from 1.8 in 1.9CR1 (issue also seems present in the beta version).

      I've attached the offsets.dat files. The behaviour is that I run 1.8 and do some inserts on the source db to make sure everything is working. I then "upgrade" to 1.9CR1 by stopping 1.8 and transferring the offsets.dat and file_database_history to a 1.9CR1 instance.

      I then start up 1.9CR1 and run some inserts. All inserts work and everything appears to be running normally. Offsets file is also updated after the inserts. I then stop Debezium Server and start it up again. After this second start up, Debezium crashes out (logging attached).

        1. offsets_1_9_0CR1.dat
          0.3 kB
        2. offsets_1_8_0.dat
          0.2 kB
        3. Logging.txt
          33 kB

            ccranfor@redhat.com Chris Cranford
            nathan-smit-1 Nathan Smit
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Created:
              Updated:
              Resolved: