Uploaded image for project: 'Red Hat OpenShift Dev Spaces (formerly CodeReady Workspaces) '
  1. Red Hat OpenShift Dev Spaces (formerly CodeReady Workspaces)
  2. CRW-2357

[KI] Upgrading an instance of CRW 2.15 with the {devworkspace} engine enabled requires manual steps

    XMLWordPrintable

Details

    • Hide
      = Upgrading a {prod-prev-short} {prod-prev-ver} instance with the {devworkspace} engine enabled (Technology Preview)

      Upgrading a {prod-prev-short} {prod-prev-ver} instance with the {devworkspace} engine enabled (Technology Preview) is simpler than the link:https://access.redhat.com/documentation/en-us/red_hat_openshift_dev_spaces/3.0/html/administration_guide/upgrading-devspaces#upgrading-crw-2.15-on-openshift[upgrade procedure] described in the Administration Guide.

      .Workaround

      . Skip steps 1 and 2 in the link:https://access.redhat.com/documentation/en-us/red_hat_openshift_dev_spaces/3.0/html/administration_guide/upgrading-devspaces#upgrading-crw-2.15-on-openshift[upgrade procedure].

      . In step 5 of the link:https://access.redhat.com/documentation/en-us/red_hat_openshift_dev_spaces/3.0/html/administration_guide/upgrading-devspaces#upgrading-crw-2.15-on-openshift[upgrade procedure], use the following two values when setting the environment variables for the migration scripts:
      * `export PRE_MIGRATION_PRODUCT_SUBSCRIPTION_NAME=codeready-workspaces2` rather than the documented `codeready-workspaces` value
      * `export PRE_MIGRATION_PRODUCT_OPERATOR_NAMESPACE=openshift-operators` rather than the documented `openshift-workspaces` value

      . In step 6 of the link:https://access.redhat.com/documentation/en-us/red_hat_openshift_dev_spaces/3.0/html/administration_guide/upgrading-devspaces#upgrading-crw-2.15-on-openshift[upgrade procedure], run only the `./3-subscribe.sh` and `./4-wait.sh` scripts. Do not run `./1-prepare.sh` and `./2-migrate.sh`.

      [IMPORTANT]
      ====
      Support for deploying {prod-short} {prod-ver} with the {devworkspace} engine is available starting with {ocp} 4.10. Administrators must upgrade clusters running earlier versions of {ocp} to 4.10 or later before subscribing to and deploying {prod-short}.
      ====
      Show
      = Upgrading a {prod-prev-short} {prod-prev-ver} instance with the {devworkspace} engine enabled (Technology Preview) Upgrading a {prod-prev-short} {prod-prev-ver} instance with the {devworkspace} engine enabled (Technology Preview) is simpler than the link: https://access.redhat.com/documentation/en-us/red_hat_openshift_dev_spaces/3.0/html/administration_guide/upgrading-devspaces#upgrading-crw-2.15-on-openshift [upgrade procedure] described in the Administration Guide. .Workaround . Skip steps 1 and 2 in the link: https://access.redhat.com/documentation/en-us/red_hat_openshift_dev_spaces/3.0/html/administration_guide/upgrading-devspaces#upgrading-crw-2.15-on-openshift [upgrade procedure]. . In step 5 of the link: https://access.redhat.com/documentation/en-us/red_hat_openshift_dev_spaces/3.0/html/administration_guide/upgrading-devspaces#upgrading-crw-2.15-on-openshift [upgrade procedure], use the following two values when setting the environment variables for the migration scripts: * `export PRE_MIGRATION_PRODUCT_SUBSCRIPTION_NAME=codeready-workspaces2` rather than the documented `codeready-workspaces` value * `export PRE_MIGRATION_PRODUCT_OPERATOR_NAMESPACE=openshift-operators` rather than the documented `openshift-workspaces` value . In step 6 of the link: https://access.redhat.com/documentation/en-us/red_hat_openshift_dev_spaces/3.0/html/administration_guide/upgrading-devspaces#upgrading-crw-2.15-on-openshift [upgrade procedure], run only the `./3-subscribe.sh` and `./4-wait.sh` scripts. Do not run `./1-prepare.sh` and `./2-migrate.sh`. [IMPORTANT] ==== Support for deploying {prod-short} {prod-ver} with the {devworkspace} engine is available starting with {ocp} 4.10. Administrators must upgrade clusters running earlier versions of {ocp} to 4.10 or later before subscribing to and deploying {prod-short}. ====
    • Documented as Known Issue

    Description

      Migration steps to update an existing CRW 2.yy.10z instance with DevWorkspace Engine enabled to Dev Spaces 3.0:

      • open the Adminstration Guide
      • find the section Upgrading OpenShift Dev Spaces
      • follow those steps, with the 2 small changes noted above.

      Attachments

        Issue Links

          Activity

            People

              abazko Anatolii Bazko
              dnochevn Dmytro Nochevnov
              Max Leonov Max Leonov
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated: