Uploaded image for project: 'OpenShift Installer'
  1. OpenShift Installer
  2. CORS-3516

Fix envtest version check for cross-compiled artifacts

XMLWordPrintable

    • Icon: Bug Bug
    • Resolution: Done
    • Icon: Undefined Undefined
    • None
    • 4.16.0
    • Installer Core
    • None
    • False
    • None
    • False
    • OCPSTRAT-1027 - Remove Terraform from OpenShift Installer. Cross-platform preparation work
    • Sprint 253, Sprint 254

      We cannot execute cross-compiled binaries, otherwise we get an error saying:

      hack/build-cluster-api.sh: line 26: /go/src/github.com/openshift/installer/cluster-api/bin/darwin_amd64/kube-apiserver: cannot execute binary file: Exec format error

      The check should be skipped in those cases.

            rdossant Rafael Fonseca dos Santos
            rdossant Rafael Fonseca dos Santos
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated:
              Resolved: